Pat_1038(乙级) | StriveZs的博客

Pat_1038(乙级)

1038 统计同成绩学生 (20 分) 原文地址

本题要求读入 N 名学生的成绩,将获得某一给定分数的学生人数输出。

输入格式:

输入在第 1 行给出不超过 10​5​​ 的正整数 N,即学生总人数。随后一行给出 N 名学生的百分制整数成绩,中间以空格分隔。最后一行给出要查询的分数个数 K(不超过 N 的正整数),随后是 K 个分数,中间以空格分隔。

输出格式:

在一行中按查询顺序给出得分等于指定分数的学生人数,中间以空格分隔,但行末不得有多余空格。

输入样例:

10
60 75 90 55 75 99 82 90 75 50
3 75 90 88

输出样例:

3 2 0

代码:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
#include<iostream>
#include<cstdio>

using namespace std;

int main(){
int dir\[10000\]={0};
int num,temp,m;
scanf("%d",&num);
for(int i=0;i<num;i++){
scanf("%d",&temp);
dir\[temp\]++;
}
scanf("%d",&m);
for(int i=0;i<m;i++){
scanf("%d",&temp);
if(i == m-1){
cout<<dir\[temp\]<<endl;
}
else{
cout<<dir\[temp\]<<" ";
}
}
return 0;
}
StriveZs wechat
Hobby lead  creation, technology change world.
  • Post author: StriveZs
  • Post link: 1698.html
  • Copyright Notice: All articles in this blog are licensed under CC BY-NC-SA 3.0 unless stating additionally.