Pat_1051(乙级) | StriveZs的博客

Pat_1051(乙级)

1051 复数乘法 (15 分)  原文地址

复数可以写成 (A+Bi) 的常规形式,其中 A 是实部,B 是虚部,i 是虚数单位,满足 i​2​​=−1;也可以写成极坐标下的指数形式 (R×e​(Pi)​​),其中 R 是复数模,P 是辐角,i 是虚数单位,其等价于三角形式 (R(cos§+isin§)。 现给定两个复数的 R 和 P,要求输出两数乘积的常规形式。

输入格式:

输入在一行中依次给出两个复数的 R​1​​, P​1​​, R​2​​, P​2​​,数字间以空格分隔。

输出格式:

在一行中按照 A+Bi 的格式输出两数乘积的常规形式,实部和虚部均保留 2 位小数。注意:如果 B 是负数,则应该写成 A-|B|i 的形式。

输入样例:

2.3 3.5 5.2 0.4

输出样例:

-8.68-8.23i

代码:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
#include <stdio.h>
#include <math.h>
//思路:根据提供指数形式进行乘法,然后在转换为sin() cos()的形式
int main()
{
double R1, P1, R2, P2;
double A, B;
scanf("%lf %lf %lf %lf", &R1, &P1, &R2, &P2);
A = R1 * R2 * cos(P1 + P2);
B = R1 * R2 * sin(P1 + P2);
if(A < 0 && A > -0.005){
A = 0;
}
if(B < 0 && B > -0.005){
B = 0;
}
printf("%.2lf%+.2lfi", A, B);
return 0;
}
StriveZs wechat
Hobby lead  creation, technology change world.
  • Post author: StriveZs
  • Post link: 1725.html
  • Copyright Notice: All articles in this blog are licensed under CC BY-NC-SA 3.0 unless stating additionally.