Pat_1059(乙级) | StriveZs的博客

Pat_1059(乙级)

1059 C语言竞赛 (20 分)  原文地址

C 语言竞赛是浙江大学计算机学院主持的一个欢乐的竞赛。既然竞赛主旨是为了好玩,颁奖规则也就制定得很滑稽:

  • 0、冠军将赢得一份“神秘大奖”(比如很巨大的一本学生研究论文集……)。
  • 1、排名为素数的学生将赢得最好的奖品 —— 小黄人玩偶!
  • 2、其他人将得到巧克力。

给定比赛的最终排名以及一系列参赛者的 ID,你要给出这些参赛者应该获得的奖品。

输入格式:

输入第一行给出一个正整数 N(≤10​4​​),是参赛者人数。随后 N 行给出最终排名,每行按排名顺序给出一位参赛者的 ID(4 位数字组成)。接下来给出一个正整数 K 以及 K 个需要查询的 ID。

输出格式:

对每个要查询的 ID,在一行中输出 ID: 奖品,其中奖品或者是 Mystery Award(神秘大奖)、或者是 Minion(小黄人)、或者是 Chocolate(巧克力)。如果所查 ID 根本不在排名里,打印 Are you kidding?(耍我呢?)。如果该 ID 已经查过了(即奖品已经领过了),打印 ID: Checked(不能多吃多占)。

输入样例:

6
1111
6666
8888
1234
5555
0001
6
8888
0001
1111
2222
8888
2222

输出样例:

8888: Minion
0001: Chocolate
1111: Mystery Award
2222: Are you kidding?
8888: Checked
2222: Are you kidding?

代码:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
#include <iostream>
#include <map>
#include <math.h>
#include <cstdio>
//思路通过map来存储数据 进行是否存在判断时 不需要进行遍历(使用散列表) 节省时间免去了查找所花费的时间
using namespace std;

bool isPrime(int n){
for(int i=2; i<=sqrt(n); i++){
if(n%i==0){
return false;
}
}
return true;
}

int main() {

int n;
scanf("%d", &n);
map<int, int> m;
for(int i=1; i<=n; i++){
int t;
cin>>t;
m\[t\] = i;
}

int q;
scanf("%d", &q);
for(int i=1; i<=q; i++){
int t;
scanf("%d", &t);
if(m\[t\]>0){
if(m\[t\]==1){
printf("%04d: Mystery Award\\n", t);
}
else if(isPrime(m\[t\])){
printf("%04d: Minion\\n", t);
}
else{
printf("%04d: Chocolate\\n", t);
}
m\[t\] = m\[t\] * -1;
}
else if(!m\[t\]){
printf("%04d: Are you kidding?\\n", t);
}
else{
printf("%04d: Checked\\n", t);
}
}

return 0;
}
StriveZs wechat
Hobby lead  creation, technology change world.
  • Post author: StriveZs
  • Post link: 1741.html
  • Copyright Notice: All articles in this blog are licensed under CC BY-NC-SA 3.0 unless stating additionally.