Pat_1060(乙级) | StriveZs的博客

Pat_1060(乙级)

1060 爱丁顿数 (25 分) 原文地址 英国天文学家爱丁顿很喜欢骑车。据说他为了炫耀自己的骑车功力,还定义了一个“爱丁顿数” E ,即满足有 E 天骑车超过 E 英里的最大整数 E。据说爱丁顿自己的 E 等于87。 现给定某人 N 天的骑车距离,请你算出对应的爱丁顿数 E(≤N)。

输入格式:

输入第一行给出一个正整数 N (≤10​5​​),即连续骑车的天数;第二行给出 N 个非负整数,代表每天的骑车距离。

输出格式:

在一行中给出 N 天的爱丁顿数。

输入样例:

10
6 7 6 9 3 10 8 2 7 8

输出样例:

6

代码:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
#include<iostream>
#include<algorithm>
#include<math.h>
#include<cstdio>

using namespace std;

bool cmp(int a,int b){
return a > b;
}

int main(){
int N,sum=0,aver=0;
scanf("%d",&N);
int list1\[N\];
for(int i=0;i<N;i++){
scanf("%d",&list1\[i\]);
sum += list1\[i\];
}
aver = 1;
sort(list1,list1+N,cmp);
//对排序的结果从大到小访问 如果值小于等于 计数值则结束
for(int i=0;i<N;i++){
if(list1\[i\] <= aver){
break;
}
aver++;;
}
cout<<--aver<<endl;
return 0;;
}
StriveZs wechat
Hobby lead  creation, technology change world.
  • Post author: StriveZs
  • Post link: 1743.html
  • Copyright Notice: All articles in this blog are licensed under CC BY-NC-SA 3.0 unless stating additionally.